Stable version 3.7.2 (2014-12) | 3.7.99-1 under developement (2018-01-10)

Quick links:

Install V_Sim from sources (on Unix-like platforms)↑ Return to top

Check the necessary libraries

The following libraries are required to compile V_Sim:

The following packages are not mandatory:

Download and untar the files

I suppose that you have downloaded v_sim-3.0.tar.bz2 in some working-directory and then unbzipped and untarred it:

$ bunzip2 v_sim-3.0.tar.bz2 | tar xvf -

or, if your tar command supports it:

$ tar -jxvf v_sim-3.0.tar.bz2

Configure, compile and install

In the untar directory with all the sources (v_sim-3.0 in our example), type:

In the above, ./configure has many available options. Type ./configure --help for a short explanation. It understands all the GNU basic arguments and some specific ones for V_Sim:

There are some other less important option to customize V_Sim more precisely, see configure --help for a extensive list.

When make install is done, it will copy all the following files :

Compiling from SVN sources

Before doing configure make make install, as stated before, it is necessary to generate the build system with the autotools. It requires to have installed:

Then after the svn co, issue: ./autogen.sh in V_Sim source directory.

Additional compiling information for ABINIT plug-in

Version matching

The C bindings for ABINIT are available from version 5.6. But since the feature is still considered experimental, not all versions are compatible with V_Sim. The following association of versions are known to work:

Compiling ABINIT to obtain the libabinis.a file

The libabinis.a file should be compiled for dynamic library creation (use -fPIC option on 64 bits machines with GNU compilers) and should contain the parser and its dependencies, except the wrtout(), leave_new() and timab() routines (V_Sim will provides them).

In ABINIT version 6.6.x, this is automatically done, but NetCDF and ETSF_IO support should be disabled. The following configure line is working on Linux platform with GFortran 4.4:

../configure --enable-bindings --prefix=DIR --disable-netcdf --disable-etsf-io

In this line, DIR should be replaced by a valid directory to install to. Then issue, make and make install as usual.

Compiling V_Sim ABINIT plug-in

The configure of V_Sim from version 3.5.2 will test the proper compilation of libabinis.a. Given the following configure line:

../configure --with-abinit=DIR FC=gfortran

should output the following lines:

checking for Abinit support... DIR
checking ab6_invars.h usability... yes
checking ab6_invars.h presence... yes
checking for ab6_invars.h... yes
checking ab6_symmetry.h usability... yes
checking ab6_symmetry.h presence... yes
checking for ab6_symmetry.h... yes
checking for parser capabilities in libabinis.a from DIR/lib... yes
checking for symmetry capabilities in libabinis.a from DIR/lib... yes
[...]
    Plug-ins:
[...]
    With ABINIT support:      yes
     | CFLAGS:                -IDIR/include
     | LDFLAGS LIBS:          -LDIR/lib -labinis -llapack

ABINIT library requires Lapack. It is automatically detected by the configure of V_Sim, once Lapack development packages have been installed (liblapack-dev for Debian-like distribution or lapack-devel for Fedora). For specific installation paths, use the --with-lapack option.

From ABINIT version 6.8, ETSF_IO and LibXC are also required. They are automatically looked for in standard installation directories. Non standard installation paths can be set by --with-etsf-io=DIR and --with-libxc=DIR options.

Specific points about the installation of V_Sim on MacOSX from sources↑ Return to top

Most of the explanations about how to install V_Sim on Unix-like platforms (see above) apply for the MacOS X environnement, with the following specificities.

Check the necessary libraries

It supposes that Fink is used to retrieve missing dependencies. The following libraries are required to compile and use V_Sim:

Configure, compile and install

In the untar directory, type:

The make command may raise some issues on MacOS platforms:

Before V_Sim version 3.4, the --with-opengl-path option was used instead of the two standard '--x-includes' and '--x-libraries' options. The liking problems on OpenGL should also have been fixed directly in the configure.

Install V_Sim on Windows↑ Return to top

Author : Damien Caliste

First of all, a version of GTK > 2.4 must be installed and correctly configured on the computer. If this is not the case, download an installer setup.exe from the GTK+ installers for Windows official page.

For V_Sim, there is currently no installer for Windows, but it is simple to install it by following these next instructions.

I suppose that you have downloaded v_sim-3.0.zip in some working-directory and then unzipped it (click right 'Extract here'). It thus creates a directory called V_Sim with all the files you need. The V_Sim directory can be moved wherever you want. The binary is located in V_Sim/bin.

If the contents of this V_Sim directory is modified, one must edit the file called v_sim.ini located in V_Sim/bin (here is an example). It contains the path to the required files. You just have to replace the given path by the correct paths (i.e. where you have put the V_Sim directory).

To use the ETSF plugin, the NetCDF DLL must be present on the system in the search path (the directory with V_Sim.exe or c:\WINDOWS). To get this library, go on the NetCDF website and download a binary distribution for Windows.